$re = '`^(?:rm -r?f?|(?:cp|mv))\b.*?\s/((?:etc|boot|dev|lib(?:64)?|misc|mnt|net|opt|root|sbin|srv|sys|usr|var|bin)(\s|$|/)|home(\s|$|[/]+(?![^/]+[/+])))`';
$str = 'rm -rf /public_html/ /home/dfd/fd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);