import Foundation
let pattern = #"^([0-9]{1,3}\.){3}[0-9]{1,3}(\/([0-9]|[1-2][0-9]|3[0-2]))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
192.168.0.1
192.168.0.1/
192.168.0.1/0
192.168.0.1/1
192.168.0.1/2
192.168.0.1/3
192.168.0.1/4
192.168.0.1/5
192.168.0.1/6
192.168.0.1/7
192.168.0.1/8
192.168.0.1/9
192.168.0.1/10
192.168.0.1/11
192.168.0.1/12
192.168.0.1/13
192.168.0.1/14
192.168.0.1/15
192.168.0.1/16
192.168.0.1/17
192.168.0.1/18
192.168.0.1/19
192.168.0.1/20
192.168.0.1/21
192.168.0.1/22
192.168.0.1/23
192.168.0.1/24
192.168.0.1/25
192.168.0.1/26
192.168.0.1/27
192.168.0.1/28
192.168.0.1/29
192.168.0.1/30
192.168.0.1/31
192.168.0.1/32
192.168.0.1/33
192.168.0.1/34
192.168.0.1/asd
192.168.0.1/01
192.168.0.1/00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)