using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9]{1,3}\.){3}[0-9]{1,3}(\/([0-9]|[1-2][0-9]|3[0-2]))?$";
string input = @"192.168.0.1
192.168.0.1/
192.168.0.1/0
192.168.0.1/1
192.168.0.1/2
192.168.0.1/3
192.168.0.1/4
192.168.0.1/5
192.168.0.1/6
192.168.0.1/7
192.168.0.1/8
192.168.0.1/9
192.168.0.1/10
192.168.0.1/11
192.168.0.1/12
192.168.0.1/13
192.168.0.1/14
192.168.0.1/15
192.168.0.1/16
192.168.0.1/17
192.168.0.1/18
192.168.0.1/19
192.168.0.1/20
192.168.0.1/21
192.168.0.1/22
192.168.0.1/23
192.168.0.1/24
192.168.0.1/25
192.168.0.1/26
192.168.0.1/27
192.168.0.1/28
192.168.0.1/29
192.168.0.1/30
192.168.0.1/31
192.168.0.1/32
192.168.0.1/33
192.168.0.1/34
192.168.0.1/asd
192.168.0.1/01
192.168.0.1/00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}