#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{1,3}\.){3}[0-9]{1,3}(\/([0-9]|[1-2][0-9]|3[0-2]))?$"
Local $sString = "192.168.0.1" & @CRLF & _
"192.168.0.1/" & @CRLF & _
"192.168.0.1/0" & @CRLF & _
"192.168.0.1/1" & @CRLF & _
"192.168.0.1/2" & @CRLF & _
"192.168.0.1/3" & @CRLF & _
"192.168.0.1/4" & @CRLF & _
"192.168.0.1/5" & @CRLF & _
"192.168.0.1/6" & @CRLF & _
"192.168.0.1/7" & @CRLF & _
"192.168.0.1/8" & @CRLF & _
"192.168.0.1/9" & @CRLF & _
"192.168.0.1/10" & @CRLF & _
"192.168.0.1/11" & @CRLF & _
"192.168.0.1/12" & @CRLF & _
"192.168.0.1/13" & @CRLF & _
"192.168.0.1/14" & @CRLF & _
"192.168.0.1/15" & @CRLF & _
"192.168.0.1/16" & @CRLF & _
"192.168.0.1/17" & @CRLF & _
"192.168.0.1/18" & @CRLF & _
"192.168.0.1/19" & @CRLF & _
"192.168.0.1/20" & @CRLF & _
"192.168.0.1/21" & @CRLF & _
"192.168.0.1/22" & @CRLF & _
"192.168.0.1/23" & @CRLF & _
"192.168.0.1/24" & @CRLF & _
"192.168.0.1/25" & @CRLF & _
"192.168.0.1/26" & @CRLF & _
"192.168.0.1/27" & @CRLF & _
"192.168.0.1/28" & @CRLF & _
"192.168.0.1/29" & @CRLF & _
"192.168.0.1/30" & @CRLF & _
"192.168.0.1/31" & @CRLF & _
"192.168.0.1/32" & @CRLF & _
"192.168.0.1/33" & @CRLF & _
"192.168.0.1/34" & @CRLF & _
"192.168.0.1/asd" & @CRLF & _
"192.168.0.1/01" & @CRLF & _
"192.168.0.1/00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")