re = /\.com\/./m
str = 'https://peninsulacanada.com/
https://peninsulacanada.com/pricing/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end