package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.com\/.`)
var str = `https://peninsulacanada.com/
https://peninsulacanada.com/pricing/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}