$re = '/\.com\/./m';
$str = 'https://peninsulacanada.com/
https://peninsulacanada.com/pricing/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);