import Foundation
let pattern = #"([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})|(_(.){3,})|((\$)(.+)|(.+)(\$))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
0e03dfdb-5da2-4167-ab2f-08d3e8f6db6c
0ea62b35-2c70-4e21-2ffd-08d3e62bd454
0f60ba13-e8ad-45dc-5479-08d3eb558eb1
0f8ff43d-3a90-4b0c-9390-08d3e13712c0
0fc8ca8b-418d-4c63-2b8e-08d3e933f221
10112770-4b4a-4b9f-b4bb-08d3e91e380c
1016f4ef-4a87-4081-6505-08d3f575421e
104ba594-900d-4162-ff57-08d3fd6de3d0
_zeus
_zeusweb
_zoyager
__vmware_xyz
somename123$
$someothername123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)