#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})|(_(.){3,})|((\$)(.+)|(.+)(\$))"
Local $sString = "0e03dfdb-5da2-4167-ab2f-08d3e8f6db6c" & @CRLF & _
"0ea62b35-2c70-4e21-2ffd-08d3e62bd454" & @CRLF & _
"0f60ba13-e8ad-45dc-5479-08d3eb558eb1" & @CRLF & _
"0f8ff43d-3a90-4b0c-9390-08d3e13712c0" & @CRLF & _
"0fc8ca8b-418d-4c63-2b8e-08d3e933f221" & @CRLF & _
"10112770-4b4a-4b9f-b4bb-08d3e91e380c" & @CRLF & _
"1016f4ef-4a87-4081-6505-08d3f575421e" & @CRLF & _
"104ba594-900d-4162-ff57-08d3fd6de3d0" & @CRLF & _
"_zeus" & @CRLF & _
"_zeusweb" & @CRLF & _
"_zoyager" & @CRLF & _
"__vmware_xyz" & @CRLF & _
"somename123$" & @CRLF & _
"$someothername123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")