# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})|(_(.){3,})|((\$)(.+)|(.+)(\$))"
test_str = ("0e03dfdb-5da2-4167-ab2f-08d3e8f6db6c\n"
"0ea62b35-2c70-4e21-2ffd-08d3e62bd454\n"
"0f60ba13-e8ad-45dc-5479-08d3eb558eb1\n"
"0f8ff43d-3a90-4b0c-9390-08d3e13712c0\n"
"0fc8ca8b-418d-4c63-2b8e-08d3e933f221\n"
"10112770-4b4a-4b9f-b4bb-08d3e91e380c\n"
"1016f4ef-4a87-4081-6505-08d3f575421e\n"
"104ba594-900d-4162-ff57-08d3fd6de3d0\n"
"_zeus\n"
"_zeusweb\n"
"_zoyager\n"
"__vmware_xyz\n"
"somename123$\n"
"$someothername123\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.