re = /(?<!^)((?<=[a-z])[A-Z0-9]|[A-Z](?=[a-z]))/m
str = 'Situacao",
PES_TIPO_PESSOA",
CedenteCnpjCpf",
TIT_CEDENTE_ENT_CODIGO",
CedenteNome",
Cnae",
SecaoCNAEDescricao",
NotaPdd",
SAC_TIPO_PESSOA",
SacadoCnpjCpf",
SacadoNome",
IdTituloVortx",
TipoAtivo",
DataEmissao",
DataAquisicao",
DataVencimento",
NumeroBoleto",
NumeroTitulo",
CampoChave",
ValorAquisicao",
ValorNominal",
ValorPresente",
PDDNota",
PDDVencido",
PagamentoParcial",
Coobricacao",
DataGeracao",
PDDTotal",
CampoAdicional1",
CampoAdicional2",
CampoAdicional3",
CampoAdicional4",
CampoAdicional5,
Campo22Adicional5
camelCase'
subst = '_\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result