const regex = new RegExp('(?<!^)((?<=[a-z])[A-Z0-9]|[A-Z](?=[a-z]))', 'gm')
const str = `Situacao",
PES_TIPO_PESSOA",
CedenteCnpjCpf",
TIT_CEDENTE_ENT_CODIGO",
CedenteNome",
Cnae",
SecaoCNAEDescricao",
NotaPdd",
SAC_TIPO_PESSOA",
SacadoCnpjCpf",
SacadoNome",
IdTituloVortx",
TipoAtivo",
DataEmissao",
DataAquisicao",
DataVencimento",
NumeroBoleto",
NumeroTitulo",
CampoChave",
ValorAquisicao",
ValorNominal",
ValorPresente",
PDDNota",
PDDVencido",
PagamentoParcial",
Coobricacao",
DataGeracao",
PDDTotal",
CampoAdicional1",
CampoAdicional2",
CampoAdicional3",
CampoAdicional4",
CampoAdicional5,
Campo22Adicional5
camelCase`;
const subst = `_\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);