# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!^)((?<=[a-z])[A-Z0-9]|[A-Z](?=[a-z]))/_\1/gm;t' <<< "Situacao\",
PES_TIPO_PESSOA\",
CedenteCnpjCpf\",
TIT_CEDENTE_ENT_CODIGO\",
CedenteNome\",
Cnae\",
SecaoCNAEDescricao\",
NotaPdd\",
SAC_TIPO_PESSOA\",
SacadoCnpjCpf\",
SacadoNome\",
IdTituloVortx\",
TipoAtivo\",
DataEmissao\",
DataAquisicao\",
DataVencimento\",
NumeroBoleto\",
NumeroTitulo\",
CampoChave\",
ValorAquisicao\",
ValorNominal\",
ValorPresente\",
PDDNota\",
PDDVencido\",
PagamentoParcial\",
Coobricacao\",
DataGeracao\",
PDDTotal\",
CampoAdicional1\",
CampoAdicional2\",
CampoAdicional3\",
CampoAdicional4\",
CampoAdicional5,
Campo22Adicional5
camelCase"