re = /(?:[^:]+:\/\/)(?:www\.)*([.a-z0-9]+)+/
str = 'https://www.polygon.com/guides/2019/2/22/18225349/tetris-strategy-tips-how-to-jonas-neubauer'
# Print the match result
str.match(re) do |match|
puts match.to_s
end