$re = '/(?:[^:]+:\/\/)(?:www\.)*([.a-z0-9]+)+/';
$str = 'https://www.polygon.com/guides/2019/2/22/18225349/tetris-strategy-tips-how-to-jonas-neubauer';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);