const regex = /(?:[^:]+:\/\/)(?:www\.)*([.a-z0-9]+)+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[^:]+:\\\/\\\/)(?:www\\.)*([.a-z0-9]+)+', '')
const str = `https://www.polygon.com/guides/2019/2/22/18225349/tetris-strategy-tips-how-to-jonas-neubauer`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}