re = /\$scope\.[a-zA-Z]*\s\=\[/
str = '$scope.proveedores =[{asdk oiaduas asoid a}]
$scope.cleintes =[{asdk oiaduas asoid a}]
$scope.ubicaciones =[{asdk oiaduas asoid a}]
$scope.loremipsum =[{asdk oiaduas asoid a}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end