const regex = /\$scope\.[a-zA-Z]*\s\=\[/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$scope\\.[a-zA-Z]*\\s\\=\\[', 'g')
const str = `\$scope.proveedores =[{asdk oiaduas asoid a}]
\$scope.cleintes =[{asdk oiaduas asoid a}]
\$scope.ubicaciones =[{asdk oiaduas asoid a}]
\$scope.loremipsum =[{asdk oiaduas asoid a}]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}