#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$scope\.[a-zA-Z]*\s\=\["
Local $sString = "$scope.proveedores =[{asdk oiaduas asoid a}]" & @CRLF & _
"" & @CRLF & _
"$scope.cleintes =[{asdk oiaduas asoid a}]" & @CRLF & _
"" & @CRLF & _
"$scope.ubicaciones =[{asdk oiaduas asoid a}]" & @CRLF & _
"" & @CRLF & _
"$scope.loremipsum =[{asdk oiaduas asoid a}]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")