const regex = /^(["']?)(\$?([0-9]{1,3},([0-9]{3},?)*[0-9]{3}|[0-9]{1,3})((.[0-9]{0,3})[0-9]{0,10})?)\1$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(["\']?)(\\$?([0-9]{1,3},([0-9]{3},?)*[0-9]{3}|[0-9]{1,3})((.[0-9]{0,3})[0-9]{0,10})?)\\1$', 'gm')
const str = `123456
123.
.
.123
123.154574
.545.4584
+1454
+487.54587
-54587.7487
.1225-
.456+
454.4+
454.455874
45.45745687687.5678
45,547
45,5
,154567891021
0,154567891021
123,1023458748
4546587,54587867
578,4
0
.123
0.00145
0.0
012345678910
1,345.154
4,330,234.34
5.545445454
3,023,123.34
12.1
5,356.12345678910
1.20
1.01
0.52
125.30
158,265.36
100,100,100,123,125,568,000.00
""
''
"1"
'1'
"123"
'123'
"123.1"
'0'
"123.12345647891"
"19,741.24"
1234567891023154546574568768767866876767676876584764646546546465465464564564.240
"191741.240"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}