#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(["']?)(\$?([0-9]{1,3},([0-9]{3},?)*[0-9]{3}|[0-9]{1,3})((.[0-9]{0,3})[0-9]{0,10})?)\1$"
Local $sString = "123456" & @CRLF & _
"123." & @CRLF & _
"." & @CRLF & _
".123" & @CRLF & _
"123.154574" & @CRLF & _
".545.4584" & @CRLF & _
"+1454" & @CRLF & _
"+487.54587" & @CRLF & _
"-54587.7487" & @CRLF & _
".1225-" & @CRLF & _
".456+" & @CRLF & _
"454.4+" & @CRLF & _
"454.455874" & @CRLF & _
"45.45745687687.5678" & @CRLF & _
"45,547" & @CRLF & _
"45,5" & @CRLF & _
",154567891021" & @CRLF & _
"0,154567891021" & @CRLF & _
"123,1023458748" & @CRLF & _
"4546587,54587867" & @CRLF & _
"578,4" & @CRLF & _
"0" & @CRLF & _
".123" & @CRLF & _
"0.00145" & @CRLF & _
"0.0" & @CRLF & _
"012345678910" & @CRLF & _
"1,345.154" & @CRLF & _
"4,330,234.34" & @CRLF & _
"5.545445454" & @CRLF & _
"3,023,123.34" & @CRLF & _
"12.1" & @CRLF & _
"5,356.12345678910" & @CRLF & _
"1.20" & @CRLF & _
"1.01" & @CRLF & _
"0.52" & @CRLF & _
"125.30" & @CRLF & _
"158,265.36" & @CRLF & _
"100,100,100,123,125,568,000.00" & @CRLF & _
"""" & @CRLF & _
"''" & @CRLF & _
""1"" & @CRLF & _
"'1'" & @CRLF & _
""123"" & @CRLF & _
"'123'" & @CRLF & _
""123.1"" & @CRLF & _
"'0'" & @CRLF & _
""123.12345647891"" & @CRLF & _
""19,741.24"" & @CRLF & _
"1234567891023154546574568768767866876767676876584764646546546465465464564564.240" & @CRLF & _
""191741.240""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")