const regex = /^now\(\)([+|-][0-9]+(y|mon|d|h|m|s))*(@(y|mon|d|h|m|s))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^now\\(\\)([+|-][0-9]+(y|mon|d|h|m|s))*(@(y|mon|d|h|m|s))?', 'gm')
const str = `now()+3d@y`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}