package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^now\(\)([+|-][0-9]+(y|mon|d|h|m|s))*(@(y|mon|d|h|m|s))?`)
var str = `now()+3d@y`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}