using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^now\(\)([+|-][0-9]+(y|mon|d|h|m|s))*(@(y|mon|d|h|m|s))?";
string input = @"now()+3d@y";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}