$re = '`(?:(?:(\w[\w\-]*\w)(?:@(.+))?):)?(.+)`';
$str = 'instance_name@region:/file/path
instance_name:/file/path
/file/path';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);