using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:(\w[\w\-]*\w)(?:@(.+))?):)?(.+)";
string input = @"instance_name@region:/file/path
instance_name:/file/path
/file/path";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}