package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:(\w[\w\-]*\w)(?:@(.+))?):)?(.+)`)
var str = `instance_name@region:/file/path
instance_name:/file/path
/file/path`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}