# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|(?<=\s))(?!charlie@outrunthebear\.co\.uk)(\w[\w\.]*@\w+\.[\w\.]+)\b"
test_str = ("\n"
"I need a regular expression that will match email addresses, but exclude specific email addresses from the match\n\n"
"e.g. do not match;\n"
"charlie@outrunthebear.co.uk\n"
"sponge.bob@example.com\n"
"jim.bob@example.com\n"
"billy.bob@example.com\n"
"match all other email addresses;\n\n"
"may be test@example.com or a@b.com a.b.c@d.e.f.com\n"
"no.body@example.com\n"
"another.test.email@example.com\n"
"and.another.one@example.com.au")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.