import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<=\\s))(?!charlie@outrunthebear\\.co\\.uk)(\\w[\\w\\.]*@\\w+\\.[\\w\\.]+)\\b";
final String string = "\n"
+ "I need a regular expression that will match email addresses, but exclude specific email addresses from the match\n\n"
+ "e.g. do not match;\n"
+ "charlie@outrunthebear.co.uk\n"
+ "sponge.bob@example.com\n"
+ "jim.bob@example.com\n"
+ "billy.bob@example.com\n"
+ "match all other email addresses;\n\n"
+ "may be test@example.com or a@b.com a.b.c@d.e.f.com\n"
+ "no.body@example.com\n"
+ "another.test.email@example.com\n"
+ "and.another.one@example.com.au";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}