use strict;
my $str = '
I need a regular expression that will match email addresses, but exclude specific email addresses from the match
e.g. do not match;
charlie@outrunthebear.co.uk
sponge.bob@example.com
jim.bob@example.com
billy.bob@example.com
match all other email addresses;
may be test@example.com or a@b.com a.b.c@d.e.f.com
no.body@example.com
another.test.email@example.com
and.another.one@example.com.au';
my $regex = qr/(?:^|(?<=\s))(?!charlie@outrunthebear\.co\.uk)(\w[\w\.]*@\w+\.[\w\.]+)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}