re = /\[(.*?)\](\(.*?\))/m
str = '[Google](http://www.google.com)
[Regex](http://www.regex.com)
[Dev community](https://dev.to/janetracydev)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end