package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(.*?)\](\(.*?\))`)
var str = `[Google](http://www.google.com)
[Regex](http://www.regex.com)
[Dev community](https://dev.to/janetracydev)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}