$re = '/\[(.*?)\](\(.*?\))/m';
$str = '[Google](http://www.google.com)
[Regex](http://www.regex.com)
[Dev community](https://dev.to/janetracydev)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);