re = /\/geoinfo\/weather\/current\/([^\/]+)/m
str = '/geoinfo/weather/current/-83.442836,-214.974261/ddd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end