$re = '/\/geoinfo\/weather\/current\/([^\/]+)/m';
$str = '/geoinfo/weather/current/-83.442836,-214.974261/ddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);