package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/geoinfo\/weather\/current\/([^\/]+)`)
var str = `/geoinfo/weather/current/-83.442836,-214.974261/ddd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}