// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\d{3,4}\s*)?\D{2}(\s*\d{3,4})?").unwrap();
let string = "AD0200
PQ 200
sk 0315
0300AD
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}