$re = '/(\d{3,4}\s*)?\D{2}(\s*\d{3,4})?/mi';
$str = 'AD0200
PQ 200
sk 0315
0300AD
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);