const regex = /(\d{3,4}\s*)?\D{2}(\s*\d{3,4})?/mig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3,4}\\s*)?\\D{2}(\\s*\\d{3,4})?', 'mig')
const str = `AD0200
PQ 200
sk 0315
0300AD
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}