re = /\d{1,10}/
str = '1
12
123
1234
12345
123456
1234567
12345678
123456789
1234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end