package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,10}`)
var str = `1
12
123
1234
12345
123456
1234567
12345678
123456789
1234567890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}