const regex = /\d{1,10}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,10}', 'g')
const str = `1
12
123
1234
12345
123456
1234567
12345678
123456789
1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}