#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{4})(-(0[1-9]|1[0-2])(-([12]\d|0[1-9]|3[01]))([T\s]((([01]\d|2[0-3])((:)[0-5]\d))([\:]\d+)?)?(:[0-5]\d([\.]\d+)?)?([zZ]|([\+-])([01]\d|2[0-3]):?([0-5]\d)?)?)?)$"
Local $sString = " 2009-12T12:34" & @CRLF & _
"" & @CRLF & _
"2009" & @CRLF & _
"2009-05-19T08:39:22.000Z" & @CRLF & _
"" & @CRLF & _
"2009-05-19" & @CRLF & _
"" & @CRLF & _
"2009-05-19" & @CRLF & _
"" & @CRLF & _
"20090519" & @CRLF & _
"" & @CRLF & _
"2009123" & @CRLF & _
"" & @CRLF & _
"2009-05" & @CRLF & _
"" & @CRLF & _
"2009-123" & @CRLF & _
"" & @CRLF & _
"2009-222" & @CRLF & _
"" & @CRLF & _
"2009-001" & @CRLF & _
"" & @CRLF & _
"2009-W01-1" & @CRLF & _
"" & @CRLF & _
"2009-W51-1" & @CRLF & _
"" & @CRLF & _
"2009-W511" & @CRLF & _
"" & @CRLF & _
"2009-W33" & @CRLF & _
"" & @CRLF & _
"2009W511" & @CRLF & _
"" & @CRLF & _
"2009-05-19" & @CRLF & _
"" & @CRLF & _
"2009-05-19 00:00" & @CRLF & _
"" & @CRLF & _
"2009-05-19 14" & @CRLF & _
"" & @CRLF & _
"2009-05-19 14:31" & @CRLF & _
"" & @CRLF & _
"2009-05-19 14:39:22" & @CRLF & _
"" & @CRLF & _
"2009-05-19T14:39Z" & @CRLF & _
"" & @CRLF & _
"2009-W21-2" & @CRLF & _
"" & @CRLF & _
"2009-W21-2T01:22" & @CRLF & _
"" & @CRLF & _
"2009-139" & @CRLF & _
"" & @CRLF & _
"2009-05-19 14:39:22-06:00" & @CRLF & _
"" & @CRLF & _
"2009-05-19 14:39:22+0600" & @CRLF & _
"" & @CRLF & _
"2009-05-19 14:39:22-01" & @CRLF & _
"" & @CRLF & _
"20090621T0545Z" & @CRLF & _
"" & @CRLF & _
"2007-04-06T00:00" & @CRLF & _
"" & @CRLF & _
"2007-04-05T24:00" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16:23:48.5" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16:23:48,444" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16:23:48,3-06:00" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16:23.4" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16:23,25" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16:23.33+0600" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16.23334444" & @CRLF & _
"" & @CRLF & _
"2010-02-18T16,2283" & @CRLF & _
"" & @CRLF & _
"2009-05-19 143922.500" & @CRLF & _
"" & @CRLF & _
"2009-05-19 1439,55"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")