# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^%>\s]+)"
test_str = ("51.23%\n"
"17.84%\n"
"72.31%\n"
"59.31%\n"
"64.48%\n"
"0.19%\n"
"1.13%\n"
"0.00%\n"
"0.00%\n"
"32.18%\n"
"0.00%\n"
"11.68%\n"
"35.60%\n"
"10.36%\n"
"0.00%\n"
"50.99%\n"
"84.03%\n"
"2.96%\n"
"47.17%\n"
"57.53%\n"
"> 90%\n"
"64.49%\n"
"59.04%\n"
"85.09%\n"
"74.25%\n"
"0.00%\n"
"0.00%\n"
"85.00%\n"
"16.13%\n"
"35.09%\n"
"12.14%\n"
"0.00%\n"
"54.82%\n"
"86.50%\n"
"0.00%\n"
"77.30%\n"
"0.15%\n"
"46.89%\n"
"89.56%\n"
"34.88%\n\n"
"0.00%\n\n\n\n"
"4.66%\n"
"0.00%\n"
"0.00%\n"
"0.00%\n"
"24.49%\n"
"28.44%\n\n"
"0.00%\n"
"0.00%\n"
"2.17%\n"
"41.77%\n"
"11.59%\n"
"0.00%\n"
"26.14%\n\n\n"
"0.90%\n"
"> 90%\n"
"73.00%\n"
"15.18%\n"
"0.00%\n"
"0.00%\n"
"7.41%\n"
"> 90%\n"
"> 90%\n"
"63.89%\n"
"89.58%\n"
"75.06%\n"
"85.52%\n"
"59.10%\n"
"38.19%\n"
"44.98%\n"
"83.05%\n"
"35.33%\n"
"62.60%\n"
"> 90%\n"
"> 90%\n"
"15.05%\n"
"0.00%\n"
"> 90%\n"
"15.21%\n"
"0.00%\n"
"7.26%\n"
"0.00%\n"
"0.00%")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.