import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^%>\\s]+)";
final String string = "51.23%\n"
+ "17.84%\n"
+ "72.31%\n"
+ "59.31%\n"
+ "64.48%\n"
+ "0.19%\n"
+ "1.13%\n"
+ "0.00%\n"
+ "0.00%\n"
+ "32.18%\n"
+ "0.00%\n"
+ "11.68%\n"
+ "35.60%\n"
+ "10.36%\n"
+ "0.00%\n"
+ "50.99%\n"
+ "84.03%\n"
+ "2.96%\n"
+ "47.17%\n"
+ "57.53%\n"
+ "> 90%\n"
+ "64.49%\n"
+ "59.04%\n"
+ "85.09%\n"
+ "74.25%\n"
+ "0.00%\n"
+ "0.00%\n"
+ "85.00%\n"
+ "16.13%\n"
+ "35.09%\n"
+ "12.14%\n"
+ "0.00%\n"
+ "54.82%\n"
+ "86.50%\n"
+ "0.00%\n"
+ "77.30%\n"
+ "0.15%\n"
+ "46.89%\n"
+ "89.56%\n"
+ "34.88%\n\n"
+ "0.00%\n\n\n\n"
+ "4.66%\n"
+ "0.00%\n"
+ "0.00%\n"
+ "0.00%\n"
+ "24.49%\n"
+ "28.44%\n\n"
+ "0.00%\n"
+ "0.00%\n"
+ "2.17%\n"
+ "41.77%\n"
+ "11.59%\n"
+ "0.00%\n"
+ "26.14%\n\n\n"
+ "0.90%\n"
+ "> 90%\n"
+ "73.00%\n"
+ "15.18%\n"
+ "0.00%\n"
+ "0.00%\n"
+ "7.41%\n"
+ "> 90%\n"
+ "> 90%\n"
+ "63.89%\n"
+ "89.58%\n"
+ "75.06%\n"
+ "85.52%\n"
+ "59.10%\n"
+ "38.19%\n"
+ "44.98%\n"
+ "83.05%\n"
+ "35.33%\n"
+ "62.60%\n"
+ "> 90%\n"
+ "> 90%\n"
+ "15.05%\n"
+ "0.00%\n"
+ "> 90%\n"
+ "15.21%\n"
+ "0.00%\n"
+ "7.26%\n"
+ "0.00%\n"
+ "0.00%";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}