#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^%>\s]+)"
Local $sString = "51.23%" & @CRLF & _
"17.84%" & @CRLF & _
"72.31%" & @CRLF & _
"59.31%" & @CRLF & _
"64.48%" & @CRLF & _
"0.19%" & @CRLF & _
"1.13%" & @CRLF & _
"0.00%" & @CRLF & _
"0.00%" & @CRLF & _
"32.18%" & @CRLF & _
"0.00%" & @CRLF & _
"11.68%" & @CRLF & _
"35.60%" & @CRLF & _
"10.36%" & @CRLF & _
"0.00%" & @CRLF & _
"50.99%" & @CRLF & _
"84.03%" & @CRLF & _
"2.96%" & @CRLF & _
"47.17%" & @CRLF & _
"57.53%" & @CRLF & _
"> 90%" & @CRLF & _
"64.49%" & @CRLF & _
"59.04%" & @CRLF & _
"85.09%" & @CRLF & _
"74.25%" & @CRLF & _
"0.00%" & @CRLF & _
"0.00%" & @CRLF & _
"85.00%" & @CRLF & _
"16.13%" & @CRLF & _
"35.09%" & @CRLF & _
"12.14%" & @CRLF & _
"0.00%" & @CRLF & _
"54.82%" & @CRLF & _
"86.50%" & @CRLF & _
"0.00%" & @CRLF & _
"77.30%" & @CRLF & _
"0.15%" & @CRLF & _
"46.89%" & @CRLF & _
"89.56%" & @CRLF & _
"34.88%" & @CRLF & _
"" & @CRLF & _
"0.00%" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4.66%" & @CRLF & _
"0.00%" & @CRLF & _
"0.00%" & @CRLF & _
"0.00%" & @CRLF & _
"24.49%" & @CRLF & _
"28.44%" & @CRLF & _
"" & @CRLF & _
"0.00%" & @CRLF & _
"0.00%" & @CRLF & _
"2.17%" & @CRLF & _
"41.77%" & @CRLF & _
"11.59%" & @CRLF & _
"0.00%" & @CRLF & _
"26.14%" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0.90%" & @CRLF & _
"> 90%" & @CRLF & _
"73.00%" & @CRLF & _
"15.18%" & @CRLF & _
"0.00%" & @CRLF & _
"0.00%" & @CRLF & _
"7.41%" & @CRLF & _
"> 90%" & @CRLF & _
"> 90%" & @CRLF & _
"63.89%" & @CRLF & _
"89.58%" & @CRLF & _
"75.06%" & @CRLF & _
"85.52%" & @CRLF & _
"59.10%" & @CRLF & _
"38.19%" & @CRLF & _
"44.98%" & @CRLF & _
"83.05%" & @CRLF & _
"35.33%" & @CRLF & _
"62.60%" & @CRLF & _
"> 90%" & @CRLF & _
"> 90%" & @CRLF & _
"15.05%" & @CRLF & _
"0.00%" & @CRLF & _
"> 90%" & @CRLF & _
"15.21%" & @CRLF & _
"0.00%" & @CRLF & _
"7.26%" & @CRLF & _
"0.00%" & @CRLF & _
"0.00%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")