# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\d\d[2468][048]|\d\d[13579][26]|\d\d0[48]|[02468][048]00|[13579][26]00)-02-29|\d{4}-((0[13578]|1[02])-(0[1-9]|[12]\d|3[01])|(0[469]|11)-(0[1-9]|[12]\d|30)|(02)-(0[1-9]|1\d|2[0-8])))T([01]\d|2[0-3]):[0-5]\d:[0-5]\d\.\d{3}([+-]([01]\d|2[0-3]):[0-5]\d|Z)$"
test_str = ("2023-02-28T00:00:00.000Z\n"
"2023-02-29T00:00:00.000Z\n"
"2024-02-29T00:00:00.000Z\n"
"2023-06-30T00:00:00.000Z\n"
"2023-06-31T00:00:00.000Z\n"
"2023-07-31T00:00:00.000Z\n\n"
"2023-07-31T00:00:00.000-05:30\n\n"
"2023-07-31T00:59:59.000Z\n"
"2023-07-31T00:60:59.000Z\n"
"2023-07-31T00:59:60.000Z")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.