using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\d\d[2468][048]|\d\d[13579][26]|\d\d0[48]|[02468][048]00|[13579][26]00)-02-29|\d{4}-((0[13578]|1[02])-(0[1-9]|[12]\d|3[01])|(0[469]|11)-(0[1-9]|[12]\d|30)|(02)-(0[1-9]|1\d|2[0-8])))T([01]\d|2[0-3]):[0-5]\d:[0-5]\d\.\d{3}([+-]([01]\d|2[0-3]):[0-5]\d|Z)$";
string input = @"2023-02-28T00:00:00.000Z
2023-02-29T00:00:00.000Z
2024-02-29T00:00:00.000Z
2023-06-30T00:00:00.000Z
2023-06-31T00:00:00.000Z
2023-07-31T00:00:00.000Z
2023-07-31T00:00:00.000-05:30
2023-07-31T00:59:59.000Z
2023-07-31T00:60:59.000Z
2023-07-31T00:59:60.000Z";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}