// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]{2}(\.|\s)?[0-9]{3}(\.|\s)?[0-9]{2}\n").unwrap();
let string = "80020509
80.020-050
80-250.404
80.405.405
80405.405";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}