package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{2}(\.|\s)?[0-9]{3}(\.|\s)?[0-9]{2}\n`)
var str = `80020509
80.020-050
80-250.404
80.405.405
80405.405`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}